New Member/First Time Owner - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-26-2014, 12:52 AM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Pensacola, FL
Posts: 18
New Member/First Time Owner

Hi,

Rick in Pensacola, FL here. Just joined and just bought my first Corvette this morning, 89 coupe/red/L98/AT.

I was looking for a 3rd gen Z28 for months but could only find rusty, clear coat peeling, used up relics for my price range.

Saw the 89 Corvette on craig's list, just across the bay and it was in really good condition. 85K miles, good paint and interior and pretty much ready to roll, all for $5K. Never saw a decent Z28 for $5K in months.

The only big issues with it are a miss in the engine when steady cruising and the headlights don't open all the way.

This car's pretty much been a garage queen for the last 13 years, took it out once in a while on nice days and it looks it.

Rick
Attached Images
File Type: jpg 00404_7Bcirqv5VfE_600x450.jpg (28.3 KB, 5 views)
shootnstarz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-26-2014, 03:00 AM
Junior Member
 
Djbrun's Avatar
 
Join Date: Sep 2014
Posts: 23
Sounds like you may have a bad EGR valve, this can cause your steady issue. On an L98 they are not as easy to change as most cars of that time.

The headlights I am not familiar, sorry that I can not help you there.


DJ
Djbrun is offline  
post #3 of 4 (permalink) Old 09-26-2014, 03:01 AM
Junior Member
 
Djbrun's Avatar
 
Join Date: Sep 2014
Posts: 23
Sorry, I forgot. Congrats!
Djbrun is offline  
 
post #4 of 4 (permalink) Old 09-26-2014, 01:59 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Pensacola, FL
Posts: 18
Thanks for the suggestion on the EGR. I was thinking it might be a fuel injector but it accelerates very smoothly, only steady cruising reveals the miss in the engine.

Rick
shootnstarz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome