vetteguy - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-08-2014, 02:34 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Posts: 1
Angry vetteguy

My 79 low mileage vette began to stumble badly recently. I only use Chevron techron gasoline. I decided to take it to WestCoastCorvettes in Anaheim. Going uphill on the 210 frwy the vette fluttered so bad I had to pull off, and have the vette towed. The engine was bucking like a mule. Cost me $165.00. I have never raced this car. Can any of the viewers respond by letting me know if they had had a similar issue, and how was it fixed.
Thanks,
Vetteguy
vetteguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome