C4 problems starting - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-14-2016, 02:20 AM Thread Starter
Junior Member
 
Join Date: Nov 2016
Posts: 1
C4 problems starting

I have 84 with original engine was running fine when I turned it off and tried to restart it started and died three times then would crank but never start. I just noticed that while it will turn over there are no dast lights when I turn key on nothing on dast is working not even engine check lights or stuff that comes on when you turn key on to start car nothing but engine turns over can somebody help me with what to check fuse box looks ok dont see anything blown im not a good diagnostic but I can follow instructions if I knee what to check or where to look please help or im gonna be selling for 4k I paid that much for interior and improvements
Playkash is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome