battery corrosion - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-04-2016, 10:34 PM Thread Starter
Junior Member
 
Join Date: Feb 2016
Location: Bradenton, Fl.
Posts: 1
Unhappy battery corrosion

Hello. I have a battery acid corrosion problem with my 1966 corvette. Both terminals are clean as could be however, I'm developing corrosion on the hold down plate at the actual hold down stud. Battery does not appear to have a leak so does anyone have any ideas where the problem lies? Does anyone else have this issue? Thanks for any help anyone can offer.
nutonz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome