1991 C-4 Bose Audio - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-11-2015, 05:46 PM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 1
1991 C-4 Bose Audio

I have a 1991 C-4 Convertible with the optional Bose Audio. The clock has frozen at 12:19, the system acts like it has no power and the power antenna will also not go up when the system is turned on. All the fuses in the fuse panel on the passenger side dash are OK. I am trying to find the problem. Any suggestions?
Aaron Ganz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome