Low Fuel warning, empty tank on guage - Corvette Forum
 1Likes
  • 1 Post By Dave Jorde
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-25-2017, 05:24 PM Thread Starter
Junior Member
 
Dave Jorde's Avatar
 
Join Date: Jun 2017
Location: Pala Mesa
Posts: 2
Low Fuel warning, empty tank on guage

Our 2007 Vette was filled up yesterday by my wife. The fuel gauge says empty (only driven 13 miles) and the digital panel message says "Low Fuel" "Service fuel System". Is there something I can do to reset this or am I forced to see a dealer?
Thank you in advance
Dave
[email protected] likes this.
Dave Jorde is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-29-2017, 09:39 PM
Member
 
Join Date: Jun 2017
Posts: 33
Are you using hi - grade fuel ( 91 oct. ) or higher ? If not this problem may be caused by sulfur deposits left on the sensor ... A can of techron fuel system cleaner in a full tank may solve this problem ... ( you may have to do this twice for best results ) Try this first ! ! ! ok ? Make sure to check for codes and write them down before doing a system reset ... ( disconnect battery for 30 min then reconnect and drive car ) if this dose not work , yes you may have to see the dealer .... I hope this helps Dave !
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome