completely dead - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-05-2011, 11:11 PM Thread Starter
Junior Member
 
Join Date: Feb 2010
Posts: 2
completely dead

Took my 66 out for a spin today and after parking and attempting to start it, the starter would not crank. Checked voltage at the battery, both cables, and tried a jump box w/o success. The clock, lights, and radio worked fine. The horn would not sound. I tried a jumper wire across the horn relay lugs and it started right up. The horn will not sound with or without the small wire across its terminals. After getting the car home I removed the wire from the horn relay and tried starting the car. It again started right up. Now I'm not sure whether the horn relay had anything to do with the initial problem. I have read about grounding issues with this year and that actually sounds like what I experienced - completely dead starter. I'm open to any suggestions or advice. I cannot duplicate the problem at this point.
Attached Images
File Type: jpg P1010580.jpg (95.7 KB, 4 views)
bc-bc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome