blown fuses - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-13-2008, 02:28 AM Thread Starter
 
Join Date: Nov 2008
Posts: 2
Question blown fuses

I have an '82 that is in good shape other than some electrical problem I can't figure out. At slow accelaration and deceleration, everything works fine, but if I hammer it or try any aggressive turns, it blows the fuse to the guages. Acts like a hot wire is grounding out, but I've traced everything I can think to trace. I also noticed my headlight buckets won't open, a problem that started when the fuse started blowing. I can replace the guage fuse, but the buckets still don't work properly. Could there be any relationship between the two problems?
bwbcpa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome