surging and power lose - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-14-2008, 09:14 AM Thread Starter
 
Join Date: Jun 2008
Posts: 1
Angry surging and power lose

Hi all I am new to the game
I have a 81 Red vette with a 350 chev have overhauled the carby & set timing to 8 deg, But the car has lost pickup & surging plus slightly back firing
I need help

Gazza
gazza is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-14-2008, 08:16 PM
 
Join Date: Nov 2008
Posts: 12
Taking a guess Your carb may be a little rich as well the back firing indicates your firing early meaning the timing is still off.Best to start at the begining and try again.Best of luck.
mad pad house is offline  
post #3 of 3 (permalink) Old 11-15-2008, 11:27 AM
 
Join Date: Oct 2008
Posts: 240
Smile Welcome Gazza To The Corvette Family!!!

I would have to agree with mad pad house again GOOD LUCK!!!! Tim c5garage



c5garage is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome