84 fuel pump has no power - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-21-2008, 05:46 PM Thread Starter
 
Join Date: Nov 2008
Posts: 1
84 fuel pump has no power

Greetings,
My 84 Vette does not get power to the fuel pump. Replaced the fuel pump relay, jumped D & E and the car started and ran for 2 days normally. Car died while driving under normal conditions. Replaced relay again and replaced the connector to the relay, still no power to fuel pump.

Alternative source of 12 volts to fuel pump directly and the fuel pumps works, vehicle started but ran rough and died would start again too.

Jumped the oil pressure sending unit too.

I am leaning towards ECM.

Can anyone help ???

Thank you
Jim
jimjakmc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-22-2009, 10:48 PM
 
Join Date: Feb 2009
Posts: 13
not sure about an 84, does it have a VATS system? on an 86 if the VATS is armed it shuts down the fuel pump (no 12v)

look at the c4 starting sequence you can see what triggers the fuel pump
http://www.corvetteactioncenter.com/.../idx.php/44/0/
tdr1919 is offline  
post #3 of 3 (permalink) Old 06-17-2014, 12:08 AM
Junior Member
 
Join Date: Jun 2014
Posts: 3
this last week, pulled combo send-pump unit from fuel tank.... cleaned up the contacts to ground ( corrosion ) solved no pump problem and yes the fuel pump relay already new.
As these cars get older, think corrosion.... particularly on ground return circuits to chassis.
FBryantHawkes is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome