Alternator/regulator problem - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-22-2016, 09:06 PM Thread Starter
Junior Member
 
Join Date: Apr 2016
Posts: 1
Alternator/regulator problem

I replaced 2 alternators within 15 months, they were putting out 16 - 18 volts regularly. When the 2nd one started doing the same thing I had it replaced professionally. Recently when accelerating (2300-2600 rpm's) it registers 16.9, also at night with lights on running above at or above 75 it goes up to the high 16's and the dash lights slightly fluctuate.
Has anyone had a similar problem and have any idea what is causing this
Alcoachg is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-29-2016, 04:34 PM
Junior Member
 
Join Date: Apr 2016
Posts: 23
Do you experience an unsettling grinding noise while driving?
peter123wallace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome