ray85vette - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-14-2009, 11:41 PM Thread Starter
 
Join Date: Jun 2009
Posts: 2
ray85vette

I Have 85 Vette Needs Help ,temperature Keeps Climbing At Idle(put 2 195 Thermostates In, New Water Pump ,had Radiator Checked It. Used To Hold Tempature.also Idle High At 1400 Or 1000 ,will Eventually Come Down To 750-800. Hit Gas And Idle Stays High Again. Sometimes It Runs Good On Highway But Seems To Hesitate When You Hit Gas (frustrating) Thanks For Any Help You Can Give.
ray85vette is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome