engine filling with gasoline when ignition is off - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-07-2008, 09:47 PM Thread Starter
 
Join Date: Nov 2008
Posts: 1
engine filling with gasoline when ignition is off

I have a problem with my 92 LT1. The ignition is off and the engine fills with gasoline. The engine wouldn't turn over and when i investigated there was gasoline dripping out of the catalytic converters. i have drained the engine, 6 gallons so far! it filled the entire crankcase, through the cylinders from the intake.

has anyone encountered this strange failure? what did you do, what do you think failed?
jimmccann is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-18-2008, 03:36 AM
 
Join Date: Nov 2008
Posts: 3
Pull the vacuum line off of the fuel regulater. If gas come out, thats your problem.

PK
PsychoKiller is offline  
post #3 of 5 (permalink) Old 11-18-2008, 02:11 PM
 
Join Date: Oct 2008
Posts: 240
Thumbs up I would agree with Randy on this!!!

Hope it is a easy fixs!! GOOD LUCK!!! Tim c5garage



c5garage is offline  
 
post #4 of 5 (permalink) Old 11-19-2008, 07:21 PM
Member
 
Join Date: Sep 2008
Location: Twain Harte California
Posts: 50
When you get this fixed make sure that you drain all the oil let it sit for a day or two with the drain plug out and the oil filler cap off. If you have a compressure i would blow air into the engine for a few minutes through the drain plug hole to dry out any gasoline. When you get ready to start your Vette after doing all this with the sparkplugs removed turn the engine over (You have oil in the engine at this point) like your trying to start it. This will let you get oil to the bearings without putting a load on them. I have an old dist that I removed the cam drive gear from that I put in a new rebuilt engine. I use a drill to spin it this drives the oil pump and I can oil everything in the engine without even turning the crank at all. Hope it all works out for you and you don't end up spining any bearings.
Attached Images
File Type: jpg P1010152.JPG (60.0 KB, 0 views)

Last edited by Mountainrider; 12-22-2008 at 05:22 AM.
Mountainrider is offline  
post #5 of 5 (permalink) Old 12-22-2008, 05:28 AM
Member
 
Join Date: Sep 2008
Location: Twain Harte California
Posts: 50
Did you get your Vette fixed ok?
Mountainrider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome