Auto trans problems - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-28-2008, 08:54 PM Thread Starter
Member
 
Join Date: Sep 2008
Location: Twain Harte California
Posts: 50
Auto trans problems

Well I just got this car last weekend and last night the auto tran lost overdrive and high. It still works in low and will shift to second fine. Has anyone here have this happen? Is there anything I can do other than take it to the shop? Hope someone can help!
Mountainrider is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-04-2008, 08:25 PM Thread Starter
Member
 
Join Date: Sep 2008
Location: Twain Harte California
Posts: 50
Cool Time for a new Transmission.

Well seeing that my Vette has 109k on it I am going to swap out the transmission. It has done it's job so it's time to bit the bullet. It's a big bullet but whats a guy going to do.
Attached Images
File Type: jpg P1010153.JPG (34.4 KB, 1 views)

Last edited by Mountainrider; 10-09-2008 at 09:33 AM.
Mountainrider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome