Trans fluid on a 93 w 8100 mles - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-13-2013, 12:15 AM Thread Starter
Junior Member
 
Join Date: Nov 2013
Posts: 5
Red face Trans fluid on a 93 w 8100 mles

Trans fluid looks good smells good, is at the right level, but is turning up with some small bubbles on the dipstick when hot. Is this breakdown?( cause of age) or perhaps moisture from small amounts of driving? If so is it permanent or would more drive time reverse it? OR should I just have it changed??
Thanks
weovettencrs93 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome