check engine - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-15-2008, 03:17 AM Thread Starter
 
Join Date: May 2008
Posts: 1
check engine

i got a 84 corvette crossfire 350 check engine comes on but not when i crank it up, temp runs around 235 sitting still 216 on the road just got oil changed today i only got 71,880 miles
lumbeeAInNC is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-17-2008, 09:13 PM
 
Join Date: May 2008
Posts: 14
I have an 84 as well. So I have to say that yours is running just a tad too hot. I'd put a 160 degree thermostat in and as far as the check engine light, Check to see if a code was set at the ECM, if so I belive it will show your Oxygen sensor is burnt out or just needs a new one(They wear out) All of this I assume that the car runs OK in all other regards? If not I'd be looking for a vacume leak, which will set off a check engine light as well. you give very little background to go on, but I believe this is your problem.
JTWard is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome