Failed LS7 engine - Corvette Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-17-2017, 11:45 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 1
Failed LS7 engine

My beloved 2006 Z06 LS7 engine failed about 2 months ago. Very sad situation to put it mildly. I understand that Mr. Hib Halvorson understands a great deal about these occurrences and I would like to contact him to relate my experience with this unfortunate event. If someone has his contact information, please let me know. Thanks!
Micky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Corvette Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome